ZBlogPHP 1.5升级到 1.6的步骤和主题及插件代码升级指南

前面跟大家分享了『ZBlogPHP 1.6 更新了什么?如何正确升级到 ZBlogPHP 1.6?』,不过根据该文所说的升级步骤不够权威,而且成功升级后也没有看到 ZBlogPHP 1.6 对应的两款免费主题 Zit 和 tpure,所以下面就跟大家分享 Z-Blog 官网发布的 ZBlogPHP 1.5 升级到 1.6 的步骤以及开发者更新指南——主题及插件代码升级。

前面跟大家分享了『ZBlogPHP 1.6 更新了什么?如何正确升级到 ZBlogPHP 1.6?』,不过根据该文所说的升级步骤不够权威,而且成功升级后也没有看到 ZBlogPHP 1.6 对应的两款免费主题 Zit 和 tpure,所以下面就跟大家分享 Z-Blog 官网发布的 ZBlogPHP 1.5 升级到 1.6 的步骤以及开发者更新指南——主题及插件代码升级。

ZBlogPHP 1.5升级到 1.6的步骤和主题及插件代码升级指南

注意:在线升级请谨慎操作,提前做好网站备份!!! 升级后网站崩溃一般是因为启用中的插件或者主题使用了不兼容的代码,请在升级主程序前选用默认主题及禁用非官方插件,并关注所用主题或插件是否已升级适配 1.6 版本。
建议:在测试站中正常升级后再更新主站。

ZBlogPHP 1.5 升级到 1.6 的一般升级步骤

  • 通过 FTP 等方式备份整个网站目录及数据库。
  • 确认所用主题是否已有 6 兼容版本,若无法确定请切换至默认主题。
  • 确认所有插件是否已有 6 兼容版本,若无法确定请先禁用所有非官方插件。(注:官方默认主题及插件均可平稳升级)
  • 进入网站应用中心界面检查程序更新并升级。
  • 进入网站应用中心界面检查应用更新,并升级相应主题或插件。
  • 若原主题暂未更新,请尝试切换回原在用主题,若前台页面报错,则通过/zb_system/admin/index.php?act=ThemeMng 进入主题管理切换回至其它兼容主题。
  • 若原某些在用插件未更新,请尝试逐一启用,测试是否异常,若出错,则通过/zb_system/admin/index.php?act=PluginMng 进入插件管理停用不兼容插件。
  • 若更新后无法进入后台,请通过 FTP 删除不兼容主题或插件,或通过原备份恢复网站。

开发者更新指南——主题及插件代码升级

主题方面

主题在把最低版本号要求设置为 1.6 之后,请参照此条 Commit,修改使用了 ZBPJF 的相关代码: https://github.com/zblogcn/zblogphp/commit/0ee32c1f425c50c261c0e7ccddef6ebd8e20cd63#diff-e9403bfad9bf5d698be71c6172d98b53L12

即:

1、去除 comment.verifydata 接口,如果需要新增字段并校验,请使用该 commit 内新增 zbp.options.comment.inputs.test 字段的方法。

2、comment.postsuccess 替换为 comment.post.success。原参数(formData, data, textStatus, jqXhr) 内的 data 现不再是字符串,而是已经转换为 Object 的数据。

3、comment.posterror 替换为 comment.post.error,参数调整为 error, formData, textStatus, jqXhr

4、comment.reply 替换为 comment.reply.start,参数不变。

5、userinfo.savefromhtml 替换为 userinfo.readFromHtml

其它方面

废弃 TransferHTML 函数,但当前版本仍然可用。请尽快更换为 FormatString 函数,参数不变。

以上内容来自@Z-Blog Wiki

温馨提示:文章内容来自互联网资源,不代表boke112联盟赞同其观点和对其真实性负责!
版权声明:本文内容来源于互联网资源,由 boke112联盟 整理汇总,发布此文是出于传递更多信息之目的,若有来源标注错误或侵犯了您的合法权益,请与老古(QQ:2226524923)联系,老古将及时更正、删除,谢谢!
文章标签:Zblog升级更新 ,  更多热门标签>>

您可能感兴趣的文章

  • Z-BlogPHP 1.5 Zero 发布了 附应用升级指南和下载地址
  • ZBlogPHP 1.6更新了什么?如何正确升级到ZBlogPHP 1.6?